
<!doctype html>
<html lang="en-US">
  <head>
  <meta charset="utf-8">
  <meta http-equiv="x-ua-compatible" content="ie=edge">
  <meta name="viewport" content="width=device-width, initial-scale=1">
  <title>This Weekend in North Carolina: July 28-30 &ndash; Our State Magazine</title>

<!-- Start The SEO Framework by Sybre Waaijer -->
<meta name="robots" content="noodp,noydir" />
<meta name="description" content="Your curated guide to events happening across the state this weekend, from the mountains to the coast." />
<meta property="og:image" content="https://i0.wp.com/d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg?fit=1175%2C620&#038;ssl=1" />
<meta property="og:image:width" content="1175" />
<meta property="og:image:height" content="620" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="This Weekend in North Carolina: July 28-30 &ndash; Our State Magazine" />
<meta property="og:description" content="Your curated guide to events happening across the state this weekend, from the mountains to the coast." />
<meta property="og:url" content="https://www.ourstate.com/this-weekend-in-north-carolina-july-28-30/" />
<meta property="og:site_name" content="Our State Magazine" />
<meta property="article:author" content="https://www.facebook.com/ourstatemagazine/" />
<meta property="fb:app_id" content="178950756808" />
<meta property="article:published_time" content="2017-07-28" />
<meta property="article:modified_time" content="2017-07-28" />
<meta property="og:updated_time" content="2017-07-28" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ourstatemag" />
<meta name="twitter:site:id" content="@ourstatemag" />
<meta name="twitter:title" content="This Weekend in North Carolina: July 28-30 &ndash; Our State Magazine" />
<meta name="twitter:description" content="Your curated guide to events happening across the state this weekend, from the mountains to the coast." />
<meta name="twitter:image" content="https://i0.wp.com/d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg?fit=1175%2C620&#038;ssl=1" />
<meta name="twitter:image:width" content="1175" />
<meta name="twitter:image:height" content="620" />
<link rel="canonical" href="https://www.ourstate.com/this-weekend-in-north-carolina-july-28-30/" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.ourstate.com\/","name":"Our State: Celebrating North Carolina Travel, Food, and Culture"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.ourstate.com\/topics\/travel\/guides\/","name":"Guides"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/www.ourstate.com\/this-weekend-in-north-carolina-july-28-30\/","name":"This Weekend in North Carolina: July 28-30","image":"https:\/\/i0.wp.com\/d3m7xw68ay40x8.cloudfront.net\/assets\/2017\/07\/28130728\/rawpixel-com-315197.jpg?fit=1175%2C620&#038;ssl=1"}}]}</script>
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"WebSite","name":"Our State Magazine","alternateName":"Our State: Celebrating North Carolina","url":"https:\/\/www.ourstate.com\/"}</script>
<meta name="google-site-verification" content="mGGbm3tvPVNXOmBu2IbnA4jXb52AX7YGX1gbMHePbOo" />
<!-- End The SEO Framework by Sybre Waaijer | 0.01342s -->

<link rel='dns-prefetch' href='//www.ourstate.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//cardinal.surge.sh' />
<link rel='dns-prefetch' href='//assets.pinterest.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="stylesheet" href="/wp-content/plugins/revslider/rs-plugin/css/settings.css?ver=4.6.9">
<style id='rs-plugin-settings-inline-css' type='text/css'>
.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}
</style>
<link rel="stylesheet" href="/wp-content/plugins/tablepress-responsive-tables/css/responsive.dataTables.min.css?ver=1.4">
<link rel="stylesheet" href="/wp-content/plugins/tablepress/css/default.min.css?ver=1.8">
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Source+Sans+Pro:200,300,400,600">
<link rel="stylesheet" href="/wp-content/themes/ourstate/dist/styles/main.css?ver=1.03">
<link rel="stylesheet" href="/wp-content/plugins/social-pariah/assets/css/pariah.css?ver=4.7.5">
<link rel="stylesheet" href="/wp-content/plugins/jetpack/css/jetpack.css?ver=4.9">
<!--[if !IE]><!-->
<link rel="stylesheet" href="/wp-content/plugins/tablepress-responsive-tables/css/tablepress-responsive-flip.min.css?ver=1.4">
<!--<![endif]-->
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
<script>window.jQuery || document.write('<script src="/wp-includes/js/jquery/jquery.js"><\/script>')</script>
<script src="/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.tools.min.js?ver=4.6.9"></script>
<script src="/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.revolution.min.js?ver=4.6.9"></script>
<script src="/wp-content/themes/ourstate/dist/scripts/main.js"></script>
<link rel='https://api.w.org/' href='https://www.ourstate.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://www.ourstate.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ourstate.com%2Fthis-weekend-in-north-carolina-july-28-30%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ourstate.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ourstate.com%2Fthis-weekend-in-north-carolina-july-28-30%2F&#038;format=xml" />
		<script type="text/javascript">
			jQuery(document).ready(function() {
				// CUSTOM AJAX CONTENT LOADING FUNCTION
				var ajaxRevslider = function(obj) {
				
					// obj.type : Post Type
					// obj.id : ID of Content to Load
					// obj.aspectratio : The Aspect Ratio of the Container / Media
					// obj.selector : The Container Selector where the Content of Ajax will be injected. It is done via the Essential Grid on Return of Content
					
					var content = "";

					data = {};
					
					data.action = 'revslider_ajax_call_front';
					data.client_action = 'get_slider_html';
					data.token = '9081016b28';
					data.type = obj.type;
					data.id = obj.id;
					data.aspectratio = obj.aspectratio;
					
					// SYNC AJAX REQUEST
					jQuery.ajax({
						type:"post",
						url:"https://www.ourstate.com/wp-admin/admin-ajax.php",
						dataType: 'json',
						data:data,
						async:false,
						success: function(ret, textStatus, XMLHttpRequest) {
							if(ret.success == true)
								content = ret.data;								
						},
						error: function(e) {
							console.log(e);
						}
					});
					
					 // FIRST RETURN THE CONTENT WHEN IT IS LOADED !!
					 return content;						 
				};
				
				// CUSTOM AJAX FUNCTION TO REMOVE THE SLIDER
				var ajaxRemoveRevslider = function(obj) {
					return jQuery(obj.selector+" .rev_slider").revkill();
				};

				// EXTEND THE AJAX CONTENT LOADING TYPES WITH TYPE AND FUNCTION
				var extendessential = setInterval(function() {
					if (jQuery.fn.tpessential != undefined) {
						clearInterval(extendessential);
						if(typeof(jQuery.fn.tpessential.defaults) !== 'undefined') {
							jQuery.fn.tpessential.defaults.ajaxTypes.push({type:"revslider",func:ajaxRevslider,killfunc:ajaxRemoveRevslider,openAnimationSpeed:0.3});   
							// type:  Name of the Post to load via Ajax into the Essential Grid Ajax Container
							// func: the Function Name which is Called once the Item with the Post Type has been clicked
							// killfunc: function to kill in case the Ajax Window going to be removed (before Remove function !
							// openAnimationSpeed: how quick the Ajax Content window should be animated (default is 0.3)
						}
					}
				},30);
			});
		</script>
		
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style>	<link rel="canonical" href="https://www.ourstate.com/this-weekend-in-north-carolina-july-28-30/">
<link rel="icon" href="https://i0.wp.com/d3m7xw68ay40x8.cloudfront.net/assets/2015/11/05093253/cropped-OS-icon-100.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/d3m7xw68ay40x8.cloudfront.net/assets/2015/11/05093253/cropped-OS-icon-100.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/d3m7xw68ay40x8.cloudfront.net/assets/2015/11/05093253/cropped-OS-icon-100.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/d3m7xw68ay40x8.cloudfront.net/assets/2015/11/05093253/cropped-OS-icon-100.jpg?fit=270%2C270&#038;ssl=1" />

</head>
  <script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
  <body class="post-template-default single single-post postid-100694 single-format-standard custom-background this-weekend-in-north-carolina-july-28-30 sidebar-primary">
    <!--[if lt IE 9]>
      <div class="alert alert-warning">
        You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.      </div>
    <![endif]-->
    

<header class="banner">
  <div class="banner header">
    <a class="logo-link" href="https://www.ourstate.com" title="Our State Magazine">
      <img class="banner logo" src="//www.ourstate.com/wp-content/themes/ourstate/assets/svgs/pamlico-blue-logo.svg" alt="Our State">
    </a>
  </div>


  <div class="primary-nav wrapper" data-spy="affix" data-offset-top="150">
    <nav id="primary-nav" class="primary-nav inner">
			<div id="toggle-mobile-nav" class="primary-nav mobile-nav-btn">Menu
				<button class="navbar-toggle collapsed" type="button" data-toggle="collapse" data-target="#bs-navbar" aria-controls="bs-navbar" aria-expanded="false">
					<span class="sr-only">Toggle navigation</span>
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
				</button>
			</div>
      <ul id="menu-main-nav-2015" class="primary-nav nav"><li class="current-post-ancestor active menu-item menu-travel"><a href="/topics/travel/">Travel</a>
<ul class="sub-menu">
	<li class="menu-item menu-eastern"><a href="/topics/travel/eastern1/">Eastern</a></li>
	<li class="menu-item menu-central"><a href="/topics/travel/central/">Central</a></li>
	<li class="menu-item menu-western"><a href="/topics/travel/western/">Western</a></li>
	<li class="current-post-ancestor active current-post-parent menu-item menu-guides"><a href="/topics/travel/guides/">Guides</a></li>
</ul>
</li>
<li class="menu-item menu-food"><a href="/topics/food/">Food</a>
<ul class="sub-menu">
	<li class="menu-item menu-recipes"><a href="/topics/food/recipes/">Recipes</a></li>
	<li class="menu-item menu-dining"><a href="/topics/food/dining/">Dining</a></li>
	<li class="menu-item menu-drinks"><a href="/topics/food/drink/">Drinks</a></li>
</ul>
</li>
<li class="menu-item menu-nc-culture"><a href="/topics/arts-culture/">NC Culture</a>
<ul class="sub-menu">
	<li class="menu-item menu-history"><a href="https://www.ourstate.com/topics/history/">History</a></li>
	<li class="menu-item menu-life"><a href="/topics/arts-culture/life/">Life</a></li>
	<li class="menu-item menu-arts"><a href="https://www.ourstate.com/topics/arts/">Arts</a></li>
	<li class="menu-item menu-home-gardens"><a href="http://www.ourstate.com/topics/arts-culture/home-garden/">Home &#038; Gardens</a></li>
</ul>
</li>
<li class="menu-item menu-video"><a href="#">Video</a>
<ul class="sub-menu">
	<li class="menu-item menu-best-kept-secrets-of-the-triad"><a href="http://video.ourstate.com/series/best-kept-secrets-in-the-triad/">Best Kept Secrets of the Triad</a></li>
	<li class="menu-item menu-thirst-in-flight"><a href="http://video.ourstate.com/series/thirst-in-flight/">Thirst in Flight</a></li>
	<li class="menu-item menu-music-sessions"><a href="http://video.ourstate.com/series/os-sessions/">Music Sessions</a></li>
	<li class="menu-item menu-unearthed"><a href="http://video.ourstate.com/series/unearthed/">Unearthed</a></li>
	<li class="menu-item menu-recipes"><a href="http://video.ourstate.com/category/recipes/">Recipes</a></li>
</ul>
</li>
<li class="menu-item menu-magazine"><a href="#">Magazine</a>
<ul class="sub-menu">
	<li class="menu-item menu-current-issue"><a href="https://www.ourstate.com/issue/the-august-2017-issue/">Current Issue</a></li>
	<li class="menu-item menu-about-us"><a href="http://www.ourstate.com/contact-us/">About Us</a></li>
	<li class="menu-item menu-our-history"><a href="http://www.ourstate.com/our-state-history/">Our History</a></li>
	<li class="menu-item menu-employment"><a href="http://www.ourstate.com/employment/">Employment</a></li>
	<li class="menu-item menu-archives"><a href="http://digital.ncdcr.gov/cdm/home/ourstate">Archives</a></li>
	<li class="menu-item menu-advertise"><a href="http://www.ourstate.com/advertise/contact-us-about-advertising/">Advertise</a></li>
	<li class="menu-item menu-contributor-guidelines"><a href="http://www.ourstate.com/contributor-guidelines/">Contributor Guidelines</a></li>
</ul>
</li>
</ul>			<ul id="menu-primary-nav-right" class="primary-nav primary-nav-right nav "><li class=" menu-subscribe menu-item menu-subscribe"><a href="http://www.ourstate.com/subscriptions/regular-subscriptions/">Subscribe</a>
<ul class="sub-menu">
	<li class=" menu-print-subscription menu-item menu-print-subscription"><a href="https://ourstate.com/subscriptions/regular-subscriptions/">Print Subscription</a></li>
	<li class=" menu-gift-subscription menu-item menu-gift-subscription"><a href="https://www.ourstate.com/subscriptions/gift-subscriptions/">Gift Subscription</a></li>
	<li class=" menu-trial-subscription menu-item menu-trial-subscription"><a href="https://ourstate.com/subscriptions/trial-subscriptions/">Trial Subscription</a></li>
	<li class=" menu-digital-subscription menu-item menu-digital-subscription"><a href="https://ourstate.com/subscriptions/digital/">Digital Subscription</a></li>
	<li class=" menu-manage-my-account menu-item menu-manage-my-account"><a href="https://account.ourstate.com/">Manage My Account</a></li>
</ul>
</li>
<li class=" menu-newsletters menu-item menu-newsletters"><a href="http://ourstate.com/our-state-newsletters/">Newsletters</a></li>
<li class=" menu-more menu-item menu-more"><a href="#">More</a>
<ul class="sub-menu">
	<li class=" menu-beer-nc-app menu-item menu-beer-nc-app"><a href="http://beerncapp.com/">BEER NC App</a></li>
	<li class=" menu-bbq-nc-app menu-item menu-bbq-nc-app"><a href="http://bbqncapp.com">BBQ NC App</a></li>
	<li class=" menu-our-state-store menu-item menu-our-state-store"><a href="http://www.ourstatestore.com">Our State Store</a></li>
	<li class=" menu-our-state-events menu-item menu-our-state-events"><a href="http://www.ourstate.events">Our State Events</a></li>
	<li class=" menu-our-state-t-v-show menu-item menu-our-state-t-v-show"><a href="http://www.unctv.org/content/ourstate">Our State T.V. Show</a></li>
	<li class=" menu-our-state-archives menu-item menu-our-state-archives"><a href="http://digital.ncdcr.gov/cdm/home/ourstate">Our State Archives</a></li>
	<li class=" menu-promotions menu-item menu-promotions"><a href="http://ourstate.com/topics/promotions/">Promotions</a></li>
</ul>
</li>
<li class=" menu-search menu-item menu-search"><a href="#">Search</a></li>
</ul>    </nav>
  </div>

</header>
<div class="search-box">
	<div class="close search-close">&times;</div>
		<form class="form form-search" action="/" method="get">
		<input type="text" class="input search-input" name="s" placeholder="Search">
	</form>
	<div class="recommended-wrapper">
		<div id="recommended" class="container">
		</div>
	</div>
</div>

    <div class="wrap container" role="document">
      <div class="content row">
        <main class="main">
          
	  <article class="post-100694 post type-post status-publish format-standard has-post-thumbnail hentry category-guides tag-calendar tag-events tag-july-2017 tag-weekend">
    <header class="single-post-header">
      <div class="post post-meta">

		<h1 class="post-title">This Weekend in North Carolina: July 28-30</h1>
	<div class="post-subtitle">
		<p>Your curated guide to events happening across the state this weekend, from the mountains to the coast.</p>
	 </div>
	 <div class="byline author vcard">
		 <span>written by</span> <a href="https://www.ourstate.com/author/ourstate/" rel="author" class="fn">Our State Staff</a>
	 </div>
</div>
 <div class="feature-img-wrapper">
	 <img src="https://d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg" class="img-responsive wp-post-image" alt="" srcset="https://d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg 1175w, https://d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg 300w, https://d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg 768w, https://d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg 1024w, https://d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg 750w, https://d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg 360w, https://d3m7xw68ay40x8.cloudfront.net/assets/2017/07/28130728/rawpixel-com-315197.jpg 936w" sizes="(max-width: 1175px) 100vw, 1175px">	 	 <div class="img-info">
		 	 </div>
 </div>
    </header>
    <div id="os-entry-content" class="entry-content">

      <p><em>This Weekend in North Carolina</em> events are provided by our partners and pulled from July&#8217;s <a href="https://www.ourstate.com/carolina-calendar-july-2017/" target="_blank" rel="noopener noreferrer">Dates &amp; Events section</a> in <em>Our State</em> magazine.<br />
• <a href="https://www.ourstate.com/submit-an-event/" target="_blank" rel="noopener noreferrer">Submit an event</a><br />
• <a href="mailto:sales@ourstate.com?subject=Our%20State%20Weekender%20Feature%20Interest">Submit a featured listing</a><br />
• <a href="http://www.ourstate.com/our-state-newsletters/" target="_blank" rel="noopener noreferrer">Sign up for our newsletters</a></p>
<hr />
<p><strong>Summer Storytelling Retreat and Adventure • Asheville • July 23-29</strong><br />
Storyteller Connie Regan-Blake brings insightful exercises, and feedback to help aspiring storytellers create and polish stories. Everyone is welcome — from beginners to advanced tellers — at this annual event.</p>
<p><em>Learn more: (828) 258-1113 or <a href="http://storywindow.com/" target="_blank" rel="noopener noreferrer">storywindow.com</a>.</em></p>
<p><strong>Charity Horse Show: Hunter/Jumper Blowing Rock July 25-August 6</strong><br />
Watch skilled equine competitors compete in the shadow of the Blue Ridge Mountains at this historic horse show.</p>
<p><em>Learn more: (828) 295-4700 or <a href="http://brchs.org/" target="_blank" rel="noopener noreferrer">brchs.org</a>.</em></p>
<p><strong>Real to Reel Film Festival • Kings Mountain • July 26-29 </strong><br />
This annual festival held at the Joy Performance Center showcases thought-provoking independent films from around the world. This year, a Real to Reel Kids Fest will feature films by kids, for kids.</p>
<p><em>Learn more: (704) 484-2787 or <a href="http://realtoreelfest.com/" target="_blank" rel="noopener noreferrer">realtoreelfest.com</a>.</em></p>
<p><strong>Symphony by the Lake at Chetola • Blowing Rock • July 28 (<em>Our State</em> will be here!)</strong><br />
Bring your lawn chairs and blankets to this open-air performance by Symphony of the Mountains, featuring a fireworks finale.</p>
<p><em>Learn more: (828) 295-7851 or <a href="http://symphonybythelake.com/" target="_blank" rel="noopener noreferrer">symphonybythelake.com</a>.</em></p>
<p><strong>Alleghany Quilters Guild Quilt Show • Sparta • July 28-29 </strong><br />
A variety of quilts by both guild members and nonmembers will be on display for judging. There also will be vendors, quilt turning, and a guild shop.</p>
<p><em>Learn more: (336) 372-3027 or <a href="http://alleghanyquiltersguild.com/" target="_blank" rel="noopener noreferrer">alleghanyquiltersguild.com</a>.</em></p>
<p><strong>Art and Antiques Show • Blowing Rock • July 28-30 </strong><br />
More than 5,000 square feet of gallery space will be filled with home furnishings, porcelain, jewelry, silver, art, and more from antiques dealers along the East Coast.</p>
<p><em>Learn more: (828) 295-9099 or <a href="http://blowingrockmuseum.org/" target="_blank" rel="noopener noreferrer">blowingrockmuseum.org</a>.</em></p>
<p><strong>Gazers of the Galaxy • Brevard • July 28 </strong><br />
Learn about stargazing equipment, telescope use, and constellations that can be seen during a summer in the mountains from members of the Pisgah Astronomical Research Institute.</p>
<p><em>Learn more: (828) 884-3443 or <a href="http://cfaia.org/" target="_blank" rel="noopener noreferrer">cfaia.org</a>.</em></p>
<p><strong>Sacred Ground: Bringing New Mexico Home • Flat Rock • July 14-August 6 </strong><br />
Work by Cedar Mountain artist Lucy Clark will be exhibited at the Flat Rock Gallery, and will feature elaborate clay work created with traditional methods of Native American pueblo pottery.</p>
<p><em>Learn more: (828) 698-7000 or <a href="http://galleryflatrock.com/" target="_blank" rel="noopener noreferrer">galleryflatrock.com</a>.</em></p>
<p><strong>Boeing Boeing • Davidson • July 20-30</strong><br />
This comedic play, set in the 1960s, follows bachelor Bernard, whose perfect life gets bumpy when his friend Robert comes to stay, and the three stewardesses Bernard’s engaged to are all in town at the same time.</p>
<p><strong>25th Moravian Music Festival • Winston-Salem • July 23-29</strong><br />
Choral, handbell, and instrumental performances will celebrate colonial sounds, while workshops and lectures will explore Moravian music history.</p>
<p><em>Learn more: (336) 725-0651 or <a href="http://moravianmusicfestival.org/" target="_blank" rel="noopener noreferrer">moravianmusicfestival.org</a>.</em></p>
<p><strong>Roaring Riot Rye Pale Ale Release Party • NoDa Brewing, Charlotte • July 28 </strong><br />
The Roaring Riot is a group of die-hard Carolina Panther fans, and the Roaring Riot Rye Pale Ale is a beer NoDa makes to honor that group of die-hard Carolina Panther fans. The beer itself is a super balanced, easy-drinking pale built for football season. Also, summer, as it’s just 5.5% ABV. Charlotte’s TIN Kitchen food truck will be on site cooking dinner too. Nodabrewing.com</p>
<p><em>Learn more: (704) 900-6851  or <a href="http://nodabrewing.com/" target="_blank" rel="noopener noreferrer">nodabrewing.com</a></em></p>
<p><strong>Beer Bourbon BBQ Festival • Cary • July 28-29</strong><br />
Mix the three greatest things in the world (barbecue, bourbon, and beer) in one weekend and you get this festival, held inside the town of Cary’s Booth Amphitheater. There’s a whole hog pig pickin’ and all you can handle bourbon and beer samples.</p>
<p><em>Learn more: (919) 462-2025 or <a href="http://beerandbourbon.com/" target="_blank" rel="noopener noreferrer">beerandbourbon.com</a></em></p>
<p><strong>Summer Concert Series • Oak Island • July 28</strong><br />
Kick back after a long week: As part of Oak Island’s summer concert series, a different band will perform at Middleton Soccer Field each Friday. Enjoy performances by the Tim Clark Band, Rivermist, Imitations, and more.</p>
<p><em>Learn more: (910) 278-4747 or <a href="http://oakisland.recdesk.com/" target="_blank" rel="noopener noreferrer">oakisland.recdesk.com</a>.</em></p>
<p><strong>Downtown Waterfront Market • Elizabeth City • July 29</strong><br />
This weekly market, held each Saturday, will feature art and craft vendors, farmers, growers, bakers, and performers at Mariner’s Wharf Park.</p>
<p><em>Learn more: (252) 330-8050 or <a href="http://discoverelizabethcity.com/" target="_blank" rel="noopener noreferrer">discoverelizabethcity.com</a>.</em></p>

    </div>
    <footer class="post-footer">

			<p>This story was published on <time class="updated" datetime="2017-07-28T17:12:06+00:00">July 28, 2017</time></p>

			
			
			<div class="row author author-info">
      				<div class="col-sm-2">
        	<img class="author author-img" src="https://d3m7xw68ay40x8.cloudfront.net/assets/2015/11/12183352/OS-icon-100.jpg">
				</div>
      				<div class="col-sm-10">
					<h4 class="author-link"><a href="https://www.ourstate.com/author/ourstate/" title="Posts by Our State Staff" rel="author">Our State Staff</a></h4>
        	<p class="author-bio">Since 1933, <em>Our State</em> has shared stories about North Carolina with readers both in state and around the world.  We celebrate the people and places that make this state great. From the mountains to the coast, we feature North Carolina travel, history, food, and beautiful scenic photography.</p>
				</div>
      </pre>
      </div>
          </footer>
  </article>
        </main><!-- /.main -->
                  <aside class="sidebar">
            <div class="cardinal sidebar-element-wrap" >

</div>


<div class="js-related os-popular-posts sidebar-element-wrap" style="display:block;">
	<h3>Related Articles</h3>
	<ol class="popular-post-list">
				<li class="popular-post-item">
			<a class="popular-post-link post-100677" href="https://www.ourstate.com/best-kept-secrets-in-the-triad-skywild/">Best-Kept Secrets in the Triad: SKYWILD</a>
		</li>
				<li class="popular-post-item">
			<a class="popular-post-link post-100667" href="https://www.ourstate.com/north-carolina-was-a-short-lived-royal-colony/">North Carolina was a Short-Lived Royal Colony</a>
		</li>
				<li class="popular-post-item">
			<a class="popular-post-link post-100395" href="https://www.ourstate.com/discover-a-cozy-getaway-at-the-mayton-inn-in-cary/">Discover a Cozy Getaway at The Mayton Inn in Cary</a>
		</li>
				<li class="popular-post-item">
			<a class="popular-post-link post-100511" href="https://www.ourstate.com/chicken-peach-skillet-dinner/">Chicken & Peach Skillet Dinner</a>
		</li>
				<li class="popular-post-item">
			<a class="popular-post-link post-100490" href="https://www.ourstate.com/peach-cobbler/">Peach Cobbler Recipe</a>
		</li>
				<li class="popular-post-item">
			<a class="popular-post-link post-100447" href="https://www.ourstate.com/photo-essay-fourth-of-july-on-lake-junaluska/">Photo Essay: Fourth of July on Lake Junaluska</a>
		</li>
			</ol>
</div>

<section class="widget text-8 widget_text"><h3>Newsletters</h3>			<div class="textwidget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css"/>
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//ourstate.us13.list-manage.com/subscribe/post?u=38b9476e4fa294c266dedf9f5&amp;id=19f0ffea6a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL"/>
</div>
<div class="mc-field-group input-group">
    <strong>Newsletters </strong>
    <ul><li><input type="checkbox" value="1" name="group[13009][1]" id="mce-group[13009]-13009-0"/><label for="mce-group[13009]-13009-0"> Recipes of the Week</label></li>
<li><input type="checkbox" value="2" name="group[13009][2]" id="mce-group[13009]-13009-1"/><label for="mce-group[13009]-13009-1"> Travel &amp; Events</label></li>
<li><input type="checkbox" value="4" name="group[13009][4]" id="mce-group[13009]-13009-2"/><label for="mce-group[13009]-13009-2"> Home &amp; Garden</label></li>
<li><input type="checkbox" value="8" name="group[13009][8]" id="mce-group[13009]-13009-3"/><label for="mce-group[13009]-13009-3"> This Week in NC History</label></li>
<li><input type="checkbox" value="16" name="group[13009][16]" id="mce-group[13009]-13009-4"/><label for="mce-group[13009]-13009-4"> Special Offers from Our Partners</label></li>
</ul>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_38b9476e4fa294c266dedf9f5_19f0ffea6a" tabindex="-1" value=""/></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"/></div>
    </div>
</form>
</div>

<!--End mc_embed_signup--></div>
		</section>


<div class="sidebar-current-issue sidebar-element-wrap">
	<h3>Current Issue</h3>
	<a href="https://www.ourstate.com/issue/the-august-2017-issue/">
	<img class="img-responsive" src="https://d3m7xw68ay40x8.cloudfront.net/assets/2017/07/21093723/August-2017-cover.jpg">
</a>

</div>

<div id="cardinal-lower" class="cardinal sidebar-element-wrap" >
</div>
          </aside><!-- /.sidebar -->
              </div><!-- /.content -->
    </div><!-- /.wrap -->

		
    <footer class="footer content-info">

	<div class="upper-footer">
		<div class="container">
			<div class="row">
				<div class="col-sm-3">
					<section class="widget nav_menu-11 widget_nav_menu"><h3>About Us</h3><ul id="menu-about-us-footer" class="menu"><li class=" menu-advertise-with-us menu-item menu-advertise-with-us"><a href="https://www.ourstate.com/advertise/contact-us-about-advertising/">Advertise With Us</a></li>
<li class=" menu-contact-us menu-item menu-contact-us"><a href="https://www.ourstate.com/contact-us/">Contact Us</a></li>
<li class=" menu-news-center-media-contacts menu-item menu-news-center-media-contacts"><a href="https://www.ourstate.com/?page_id=434">News Center / Media Contacts</a></li>
</ul></section>				</div>
				<div class="col-sm-3">
					<section class="widget nav_menu-10 widget_nav_menu"><h3>Submit</h3><ul id="menu-submit-pages-2015" class="menu"><li class=" menu-letter-to-the-editor menu-item menu-letter-to-the-editor"><a href="http://www.ourstate.com/letter-to-editor/">Letter to the Editor</a></li>
<li class=" menu-carolina-calendar-event menu-item menu-carolina-calendar-event"><a href="http://www.ourstate.com/submit-an-event/">Carolina Calendar Event</a></li>
<li class=" menu-speaker-request menu-item menu-speaker-request"><a href="http://www.ourstate.com/speaker-request/">Speaker Request</a></li>
<li class=" menu-general-comment menu-item menu-general-comment"><a href="http://www.ourstate.com/reader-comments/">General Comment</a></li>
<li class=" menu-ad-materials menu-item menu-ad-materials"><a href="https://www.ourstate.com/advertise/ad-specs/">Ad Materials</a></li>
</ul></section>				</div>
				<div class="col-sm-3">
					<section class="widget nav_menu-12 widget_nav_menu"><h3>More</h3><ul id="menu-more-2015" class="menu"><li class=" menu-bbq-nc-app menu-item menu-bbq-nc-app"><a href="http://bbqncapp.com">BBQ NC App</a></li>
<li class=" menu-our-state-store menu-item menu-our-state-store"><a target="_blank" href="http://www.ourstatestore.com">Our State Store</a></li>
<li class=" menu-our-state-events menu-item menu-our-state-events"><a target="_blank" href="http://www.ourstate.events">Our State Events</a></li>
<li class=" menu-our-state-t-v-show menu-item menu-our-state-t-v-show"><a href="http://www.unctv.org/content/ourstate">Our State T.V. Show</a></li>
<li class=" menu-our-state-archives-at-the-state-library-of-north-carolina menu-item menu-our-state-archives-at-the-state-library-of-north-carolina"><a target="_blank" href="http://digital.ncdcr.gov/cdm/home/ourstate">Our State Archives at the State Library of North Carolina</a></li>
<li class=" menu-promotions menu-item menu-promotions"><a href="https://www.ourstate.com/topics/promotions/">Promotions</a></li>
</ul></section>				</div>
				<div class="col-sm-3">
					<h3 class="widget-title">Follow Us </h3>
					<ul class="social-menu">
						<li>
							<a target="_blank" class="social genericon genericon-twitter social-circle" href="http://www.twitter.com/ourstatemag"></a>
						</li>
						<li>
							<a target="_blank" class="social genericon genericon-facebook-alt social-circle" href="http://www.facebook.com/ourstatemagazine"></a>
						</li>
						<li>
							<a target="_blank" class="social genericon genericon-googleplus social-circle" href="https://plus.google.com/111384339759165456841"></a>
						</li>
						<li>
							<a target="_blank" class="social genericon genericon-pinterest social-circle" href="http://www.pinterest.com/ourstate"></a>
						</li>
						<li>
							<a target="_blank" class="social genericon genericon-instagram social-circle" href="https://instagram.com/ourstatemag/"></a>
						</li>
						<li>
							<a target="_blank" class="social genericon genericon-youtube social-circle" href="https://www.youtube.com/user/ourstatemagazine/"></a>
						</li>
						<li>
							<a target="_blank" class="social genericon genericon-vimeo social-circle" href="https://vimeo.com/ourstatemagazine"></a>
						</li>
					</ul>
				</div>
			</div>
		</div>
	</div>
  <div class="lower-footer container">
    <div class="row">
			<div class="col-sm-12">
				<p class="copyright">Copyright © Our State Magazine 2017, All rights reserved.</p>
			</div>
		</div>
  </div>
</footer>

<div id="fb-root"></div>        

        <div class="pariah">
          <a id="pariah-mail" class="pariah-action pariah-mail" href="#"><svg viewBox="0 0 512 512"><path d="M101.3 141.6v228.9h0.3 308.4 0.8V141.6H101.3zM375.7 167.8l-119.7 91.5 -119.6-91.5H375.7zM127.6 194.1l64.1 49.1 -64.1 64.1V194.1zM127.8 344.2l84.9-84.9 43.2 33.1 43-32.9 84.7 84.7L127.8 344.2 127.8 344.2zM384.4 307.8l-64.4-64.4 64.4-49.3V307.8z"/></svg> Mail</a>
          <a id="pariah-pin" class="pariah-action pariah-pin" href="#"><svg viewBox="0 0 512 512"><path d="M266.6 76.5c-100.2 0-150.7 71.8-150.7 131.7 0 36.3 13.7 68.5 43.2 80.6 4.8 2 9.2 0.1 10.6-5.3 1-3.7 3.3-13 4.3-16.9 1.4-5.3 0.9-7.1-3-11.8 -8.5-10-13.9-23-13.9-41.3 0-53.3 39.9-101 103.8-101 56.6 0 87.7 34.6 87.7 80.8 0 60.8-26.9 112.1-66.8 112.1 -22.1 0-38.6-18.2-33.3-40.6 6.3-26.7 18.6-55.5 18.6-74.8 0-17.3-9.3-31.7-28.4-31.7 -22.5 0-40.7 23.3-40.7 54.6 0 19.9 6.7 33.4 6.7 33.4s-23.1 97.8-27.1 114.9c-8.1 34.1-1.2 75.9-0.6 80.1 0.3 2.5 3.6 3.1 5 1.2 2.1-2.7 28.9-35.9 38.1-69 2.6-9.4 14.8-58 14.8-58 7.3 14 28.7 26.3 51.5 26.3 67.8 0 113.8-61.8 113.8-144.5C400.1 134.7 347.1 76.5 266.6 76.5z"/></svg> Pin</a>
          <a id="pariah-fb" class="pariah-action pariah-fb" href="#"><svg viewBox="0 0 512 512"><path d="M211.9 197.4h-36.7v59.9h36.7V433.1h70.5V256.5h49.2l5.2-59.1h-54.4c0 0 0-22.1 0-33.7 0-13.9 2.8-19.5 16.3-19.5 10.9 0 38.2 0 38.2 0V82.9c0 0-40.2 0-48.8 0 -52.5 0-76.1 23.1-76.1 67.3C211.9 188.8 211.9 197.4 211.9 197.4z"/></svg> Share</a>
        </div>
      
		<script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

      ga('create', 'UA-2537210-1', 'auto');
      ga('send', 'pageview');
    </script>

    <script type="text/javascript">
      (function(d, s, id) {
      window.Wishpond = window.Wishpond || {};
      Wishpond.merchantId = '191317';
      Wishpond.writeKey = 'e02e9a26c715';
      var js, wpjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//cdn.wishpond.net/connect.js";
      wpjs.parentNode.insertBefore(js, wpjs);
      }(document, 'script', 'wishpond-connect'));
    </script>

		<!-- Facebook Pixel Code -->
		<script>
			!function(f,b,e,v,n,t,s)
			{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};
			if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
			n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];
			s.parentNode.insertBefore(t,s)}(window,document,'script',
			'https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '1039493982738873'); 
			fbq('track', 'PageView');

			
		</script>
		<noscript>
			<img height="1" width="1" src="https://www.facebook.com/tr?id=1039493982738873&ev=PageView&noscript=1"/>
		</noscript>
		<!-- End Facebook Pixel Code -->

    <script src="//platform.twitter.com/oct.js" type="text/javascript"></script>
    <script type="text/javascript">twttr.conversion.trackPid('ntm1v', { tw_sale_amount: 0, tw_order_quantity: 0 });</script>
    <noscript>
    	<img height="1" width="1" style="display:none;" alt="" src="https://analytics.twitter.com/i/adsct?txn_id=ntm1v&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
    	<img height="1" width="1" style="display:none;" alt="" src="//t.co/i/adsct?txn_id=ntm1v&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />
    </noscript>


	<script src="/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122"></script>
<script src="https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201730"></script>
<script src="/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8"></script>
<script src="https://cardinal.surge.sh/assets/js/app.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rp = {"siteUrl":"https:\/\/www.ourstate.com","posts":[{"id":100677,"post_title":"Best-Kept Secrets in the Triad: SKYWILD","post_permalink":"https:\/\/www.ourstate.com\/best-kept-secrets-in-the-triad-skywild\/","post_image":"https:\/\/d3m7xw68ay40x8.cloudfront.net\/assets\/2017\/07\/28103731\/bks-skywild1.jpg"},{"id":100667,"post_title":"North Carolina was a Short-Lived Royal Colony","post_permalink":"https:\/\/www.ourstate.com\/north-carolina-was-a-short-lived-royal-colony\/","post_image":"https:\/\/d3m7xw68ay40x8.cloudfront.net\/assets\/2017\/07\/21115800\/20170724-twinch-granville-district-map.jpg"},{"id":100395,"post_title":"Discover a Cozy Getaway at The Mayton Inn in Cary","post_permalink":"https:\/\/www.ourstate.com\/discover-a-cozy-getaway-at-the-mayton-inn-in-cary\/","post_image":"https:\/\/d3m7xw68ay40x8.cloudfront.net\/assets\/2017\/06\/28170210\/mayton-inn.jpg"}]};
/* ]]> */
</script>
<script src="/wp-content/themes/ourstate/assets/scripts/related.js?ver=v1"></script>
<script src="//assets.pinterest.com/js/pinit.js"></script>
<script src="//connect.facebook.net/en_US/sdk.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var SocialPariah = {"id":"100694","permalink":"https:\/\/www.ourstate.com\/this-weekend-in-north-carolina-july-28-30\/","title":"This Weekend in North Carolina: July 28-30","excerpt":"Your curated guide to events happening across the state this weekend, from the mountains to the coast."};
/* ]]> */
</script>
<script src="/wp-content/plugins/social-pariah/assets/js/pariah.js"></script>
<script src="/wp-includes/js/wp-embed.min.js?ver=4.7.5"></script>
<script type='text/javascript' src='https://stats.wp.com/e-201730.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.9',blog:'105771735',post:'100694',tz:'-4',srv:'www.ourstate.com'} ]);
	_stq.push([ 'clickTrackerInit', '105771735', '100694' ]);
</script>
  </body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

 Served from: ourstate.com @ 2017-07-28 14:23:30 by W3 Total Cache -->